pkgbuilds/libcxxfileno/PKGBUILD

39 lines
840 B
Bash

# Maintainer: Théophile Bastian <contact@tobast.fr>
pkgname=libcxxfileno-git
_pkgname="${pkgname%-git}"
pkgver=r17.bb4b85e
pkgrel=1
provides=($_pkgname)
conflicts=($_pkgname)
pkgdesc="Libcxxfileno by Stephen R. Kell"
arch=('x86_64')
url="https://github.com/stephenrkell/libcxxfileno"
license=('?')
depends=()
makedepends=('git' 'make' 'autoconf')
install=
source=("git+https://github.com/stephenrkell/libcxxfileno")
md5sums=('SKIP')
prepare() {
cd "$srcdir/${_pkgname}"
sed -i '1ipkgincludedir=$(includedir)' include/Makefile.am
}
pkgver() {
cd "$srcdir/${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
cd "$srcdir/${_pkgname}"
autoreconf -i
./configure --prefix=/usr
make -j
}
package() {
cd "$srcdir/${_pkgname}"
make DESTDIR="$pkgdir/" install
}